Value Stream Summary not displaying some content

Post Reply
ben.ralph.nmc
Posts: 25
Joined: 11 Apr 2022, 11:50

Hi

The value stream summary (core_bl_value_stream_summary.xsl) is not displaying 'Participants' and 'Supporting Business Processes'.

Participants have been linked to Individual_Business_Role, Supporting Processes have been linked to Business_Process in Protege. Am I missing some additional data or relationships?

Thanks
Ben
JohnM
Posts: 468
Joined: 17 Feb 2009, 20:19

We made some updates in the last release to this view, I need to confirm a few things

Can you open the view and tell me what the variable allStakeholderRoles near the top is set to.

It should be:
<xsl:variable name="allStakeholderRoles" select="/node()/simple_instance[type=('Business_Role_Type','Business_Role', 'Individual_Business_Role', 'Group_Business_Role')][name = ($currentValueStream, $vsValueStages)/own_slot_value[slot_reference = ('vs_trigger_business_roles', 'vsg_participants')]/value]"/>
ben.ralph.nmc
Posts: 25
Joined: 11 Apr 2022, 11:50

Hi John

The variable is:
<xsl:variable name="allStakeholderRoles" select="/node()/simple_instance[type=('Business_Role_Type','Business_Role')][name = ($currentValueStream, $vsValueStages)/own_slot_value[slot_reference = ('vs_trigger_business_roles', 'vsg_participants')]/value]"/>

When I replace the above with the variable you posted, the participants now appear. I guess the business process variable needs updating too?
JohnM
Posts: 468
Joined: 17 Feb 2009, 20:19

Hi Ben,

Have you downloaded the latest viewer, the changes are in there?

Thanks

John
ben.ralph.nmc
Posts: 25
Joined: 11 Apr 2022, 11:50

No I hadn't. The view is working correctly now.

Thanks
Post Reply