run_protege_server.bat error on Windows Server 2022

Post Reply
Posts: 143
Joined: 09 Feb 2023, 03:33


I checked forum here with a few similar discussion on protege server cannot start error, but not fix the problem.

I installed the multi-user environment in one Windows Server 2022, and have connected the MySQL DB in the same server.

Follow the thread suggestion viewtopic.php?f=21&t=2744&p=31355&hilit ... ion#p31355, updated my bat file, but still has the attached error message.

- SEVERE: java.rmi.ServerException: RemoteException occurred in server thread;
- Caused by: java.rmi.UnmarshalException: error unmarshalling arguments;
- Caused by: java.lang.ClassNotFoundException: edu.stanford.smi.protege.server.Server_Stub

All components are downloaded from our project site.

Any hints can help? Thanks a lot,
You do not have the required permissions to view the files attached to this post.
Posts: 137
Joined: 31 May 2012, 12:08
Location: France

Hi xiaoqi,

it may be because the rmiregistry process does not have the protege jar files in its classpath.

For me, under unix, the most robust solution was to add these jars to the classpath when launching rmiregistry using its '-J' argument :

Code: Select all

rmiregistry -J-cp -J$CLASSPATH&

I'm not proficient enough with microsoft O.S to ensure it but ... something like that in your run_protege_server.bat should work :

Code: Select all

set CLASSPATH=protege.jar;looks.jar;unicode_panel.jar;driver.jar;driver0.jar;driver1.jar
start /D%JDKBIN% /min rmiregistry.exe -J-cp -J%CLASSPATH%

Posts: 143
Joined: 09 Feb 2023, 03:33

Thanks a lot, I've added your suggested parameter in the server-start batch file, the command is running but the terminal window closed without any notice.

And I cannot find either service or task about Protege Server to prove it's running.

However, I cannot connect to server from Protege client, it says either firewall or network problem, but I have the same error pop up even I run Protege client from the same machine that server is running, using "localhost".

I'll continue troubleshoot.

Post Reply