Essential 6: Import Utility login issue

Post Reply
sandeepkhanna
Posts: 6
Joined: 30 Jan 2015, 15:54

12 May 2017, 19:43

In Essential 6, I am unable to login to the import utility, and get the following error message:
"The server is temporarily out of service.
Would you like to try again?

(467)"

I haven't been able to resolve it using the ZK property: "org.zkoss.zkex.ui.comet.smartconnection.disabled"

Thoughts/comments on how to resolve this issue?

User avatar
jonathan.carter
Posts: 951
Joined: 04 Feb 2009, 15:44

15 May 2017, 10:20

Hi,

Thanks for your post.

Unfortunately, I wouldn't expect the SmartConnection approach to resolve this.

Could you confirm precisely which version of the Import Utility application that you are using, please?
The latest release is version 1.6.5 - shown in the footer on the bottom left of the login page.

I've asked this assuming that you are at least being shown the login page?

Have you been able to import your previous configuration of the Import Utility (assuming you have one) into the new version?

Have you tried clearing relevant cached content in your browser?
Check your web application server logs for any additional messages and please feel free to post any exception details that might be in there. e.g. if you are using Tomcat, these will be in <TOMCAT INSTALL>/logs/catalina.log or catalina.out

Finally, could you tell us which browser you are using?

Thanks

Jonathan
Essential Project Team

sandeepkhanna
Posts: 6
Joined: 30 Jan 2015, 15:54

24 May 2017, 04:58

- Import Utility Version: 1.6.5
- Browsers: Tried on Chrome, Firefox and IE. All give the same error message. No cache issues.
- I am trying to run on a new installation. This is not an upgrade.
- Excerpts of Tomcat Logs:
24-May-2017 00:42:33.667 WARNING [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'maxSpareThreads' to '75' did not find a matching property.
24-May-2017 00:42:34.175 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server version: Apache Tomcat/8.0.43
...
...
24-May-2017 00:42:34.184 INFO [main] org.apache.catalina.core.AprLifecycleListener.lifecycleEvent The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files (x86)\Java\jre1.8.0_131\bin;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files (x86)\RSA SecurID Token Common;C:\Program Files\RSA SecurID Token Common;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x64;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;.
...
...
24-May-2017 00:43:04.217 WARNING [localhost-startStop-1] org.zkoss.zkex.init.WebAppInit.init:29 This is an evaluation copy of ZK EE and will terminate after sixty days from the first date of installation. Should you require an open source license or commercial license for ZK EE please contact us at [email protected] for more information. Alternatively you can download ZK CE which is licensed under the LGPL.
...
...
24-May-2017 00:43:07.662 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 31448 ms

User avatar
jonathan.carter
Posts: 951
Joined: 04 Feb 2009, 15:44

24 May 2017, 10:16

Thanks very much for posting back on this, Sandeep.

I’ve also tried out a fresh install of the v1.6.5 Import Utility on Tomcat 8 but I cannot replicate the error that you are seeing.

One thought, as this is a fresh installation of the Import Utility, is it a fresh installation of Tomcat, too? It could well be that the Import Utility is running out of heap space in the memory. I recommend that you use the 64-bit Java Virtual Machine and have the maximum memory set to 2GB (e.g. -Xms128m -Xmx2048m -XX:MaxPermSize=512m)

If all that seems correct in your installation, I did find a post about the use of Kerberos for SSO. Could that be part of your deployment? Unlike the Viewer, which can be integrated via LDAP to things like Active Directory, the Import Utility uses its own local directory and is not designed to be integrated with 3rd party Identity Management platforms.
http://clear-headed24.rssing.com/browse ... 52&item=33

Let me know how you get on

Jonathan
Essential Project Team

sandeepkhanna
Posts: 6
Joined: 30 Jan 2015, 15:54

24 May 2017, 22:39

This is a test setup with no SSO. Stand-alone machine with fresh installation of Essential, tomcat, import utility etc.

Increasing the memory did not do anything. Not having any luck with the logs, as they don't seem to point to anything. Just can't get past the login dialog for the import utility. Essential viewer on a different tomcat instance works just fine. Tried essential viewer instance to run the import utility, but get the same result. When I bring up the page containing login dialog box for import utility, the following 2 lines show up on the console (in case that points to anything), and a click on login gives the error message described in the initial post:
GETTING USER MANAGER FROM SESSION: [email protected]
GETTING USER MANAGER FROM SESSION: [email protected]

Reload of the page results in these two lines written again.

User avatar
jonathan.carter
Posts: 951
Joined: 04 Feb 2009, 15:44

25 May 2017, 17:03

Thanks for posting back.

We've tested with Chrome, Firefox, IE and Safari and are not able to replicate this, unfortunately.

It's interesting about the sessions, though. Can you check whether there are any session cookies set on your browser that the Import Utility - more specifically Tomcat - has set? If there are any, try deleting them and logging in again in case those are causing some trouble.

If you look in the webapps folder of your Tomcat 8.0.43, is the import utility web application deploying correctly? That is, it has successfully created a folder within which are a bunch of files and folders (including one called WEB-INF).

Thanks again for your help and patience

Jonathan
Essential Project Team

User avatar
jonathan.carter
Posts: 951
Joined: 04 Feb 2009, 15:44

26 May 2017, 15:04

UPDATE:

One of the things I'd found when researching this ZK issue was about having multiple versions of libraries in available to the application. I've found that we are carrying two versions of a POI library.
Could you try navigating to the <TOMCAT WEB APPS>/essential_import_utility/WEB-INF/lib folder and removing the file "poi.jar"?

Restart your Tomcat server and try again.

Thanks

Jonathan
Essential Project Team

Post Reply